Arbeiten mit LibreOffice (Writer)

From B-Ob8ungen
Jump to: navigation, search

Ein paar Sachen zur Arbeit mit LibreOffice hatte ich schon unter Ubuntu 11.10 beschrieben.

Dokumente in Wiki-Text verwandeln

Die Sache ist inzwischen geklärt. Es ist unnötig, die OpenOffice Version 2.4 (unter Windows) zu installieren. Es gibt für Libre Office eine Erweiterung (extension) mit dem Namen Wiki Publisher (bei mir in der Version 1.1.1), die unter Tools-Extension Manager (tools heißt im Deutschen "Extras") installiert werden kann. Damit können Texte mit Fuß- oder Endnoten in Wiki-Text formatiert werden. Die Zitate werden zwar alle nach dem Muster ref name=nzahl benannt, aber das fällt auf den Wiki-Seiten natürlich niemand auf.

Erwähnen sollte ich auch, dass es nun für die Rechtsschreibprüfung (spell check) ein Paket für die türkische Sprache gibt (Zemberek Turkish Spell Checker).

Fußnoten formatieren

In LibreOffice (bei mir die Version 3.4.4) ist es nicht so einfach, alle Fußnoten gleichzeitig zu formatieren. Falls ich mit CTRL+F eine einfache Suche aufrufe, erscheint ein kleines Fenster am unteren Rand. Dort werden keine Optionen angeboten. Ich muss also mit der Kombination CTRL+Alt+F (STRG+Alt+F) das Fenster für "Suchen und Ersetzen" aufrufen. Hier muss ich die Optionen aufklappen und "Search for Styles" (könnte im Deutschen: Suche nach Vorlagen heißen) anklicken. Dann kann ich im Suchfenster nach Fußnoten suchen. Sodann muss "Search for All" angeklickt werden und nun kann ich alle Fußnoten auf einmal formatieren.

Umbrüche entfernen

Das Problem taucht auf, wenn ich mit der Buchfunktion ("collection") in einem Wiki eine ODT Datei herunterlade. Hier wird jede neue Seite, aber auch jeder Abschnitt (alles, was nach einer Überschrift steht), in einen Bereich (so lautet wohl die Übersetzung von "section" bei LibreOffice verwandelt. Das hat zur Folge, dass ich mit CTRL+A immer nur einen Bereich markieren kann, also kein ganzes Dokument auf einmal formatieren kann. Es gibt zunächst einmal zwei Möglichkeiten, diese Markierungen zu entfernen.

Umbruch für Bereiche in Word entfernen

Personen, die unter Windows sowohl LibreOffice als auch Word installiert haben, können das ODT Dokument mit LibreOffice in DOC verwandeln und dann mit Word "Suchen und Ersetzen" aufrufen, die erweiterten Optionen unter "More" (mehr) Aufrufen und dann unter "Spezial" nach Umbrüche für Bereiche suchen lassen (im Suchfeld erscheint ^b). Sodann kann ich alle Umbrüche z.B. durch eine Leerzeichen ersetzen

Google Dokumente und Tabellen nutzen

Über GoogleDocs habe ich die Möglichkeit, die als ODT herunter geladenen Datei hochzuladen und sie in das von Google verwendete Format verwandeln zu lassen. Wenn ich sie öffne, alles markiere (CTRL-A) und kopiere, sind die Fußnoten ebenfalls verschwunden, aber wenn ich die Datei z.B. als DOC Datei herunterlade, sind alle Fußnoten und auch sonstige Formatierungen aber keine Umbrüche von Bereichen mehr vorhanden.

So funktioniert es in LibreOffice

Weder meine Suche im Internet, noch die Experimente in LibreOffice haben mich zu einer Lösung geführt. Auch die Einsicht, durch Umwandlung des ODT Dokumentes in HTML, dass es sich hier um einen so genannten DIV-Tag handelt, haben mich nicht weiter gebracht. Es gab auf dieser Seite zwar nützliche Anregungen zum Entfernen von Umbrüchen bei Absätzen und nebenbei habe ich von dieser Seite noch die Erweiterung AltSearch.oxt installieren können. Dies ist eine wesentliche Verbesserung der "Suche und Ersetzen" Funktion in LibreOffice.

Aber erst auf den Hilfeseiten für LibreOffice fand ich den Hinweis, wie Bereiche (sections) zu bearbeiten sind. Folgende Schritte führen zum Erfolg:

  1. Klicke in dem herunter geladenen ODT Dokument auf "Formatieren-Bereich"
  2. Es geht ein Fenster auf, in dem auf der linken die vorhandenen Bereiche zu sehen sind. Auf der rechten Seite gibt es die Option, einen Bereich zu entfernen (remove)
  3. Mit gedrückter Umschalttaste kann ich mit einem Mausklick alle Bereiche auswählen und durch "remove" alle Umbrüche für die Bereiche entfernen.

Das Ganze kann in einem kurzen Film dargestellt werden. Dieser kann notfalls mit diesem Link entweder direkt im Browser abgespielt oder mit "Ziel speichern unter" herunter geladen werden. Falls (wie geplant) ein Vorschaubild mit dem darunter angebrachten Hinweis "right click to control movie" erscheint, sollte auf das Bild mit der rechten Maustaste geklickt werden. Wenn der PC auf Deutsch eingestellt ist, gibt es Optionen wie "Steuerung anzeigen" oder "Abspielen". Es ist zu empfehlen, den Modus "Vollbild" zu wählen, um bei maximaler Lautstärke den Film in optimaler Qualität abzuspielen.

<videoflash type="html5" controls="controls" style="width:560px;height:380px;">http://ob.nubati.net/de/filme/ubuntu/libre-1.ogv</videoflash>

Das Gleiche kann noch einmal mit einem Film zum Herunterladen aller Seiten in einer Kategorie und den folgenden Möglichkeiten der Formatierung gezeigt werden. Hier ist dies der direkte Link.

<videoflash type="html5" controls="controls" style="width:560px;height:380px;">http://ob.nubati.net/de/filme/ubuntu/libre-2.ogv</videoflash>

Leeren Platz am Seitenende "entfernen"

Die als Buch herunter geladenen Dokumente enthalten nicht nur nach Überschriften, bzw. am Ende von Bereichen oft größere leere Flächen, die aber keine Leerzeilen sind. Es handelt sich auch nicht um Seitenumbrüche, die entfernt werden könnten. Zu diesem Punkt habe ich ebenfalls keine Tipps im Internet gefunden. Ich habe einfach irgendwann festgestellt, dass "normaler" Text (praktisch der gesamte Text mit Ausnahme der Überschriften) als "TextBody" markiert ist. Ich könnte nun das Format von "TextBody" verändern, aber einfacher erscheint mir:

  1. Rufe "suchen und ersetzen" auf (STRG+Alt+F)
  2. Im Fenster "Mehr Optionen" anklicken und "Suche nach Vorlagen" aktivieren
  3. Im Suchfenster (obere Teil) mit dem Pfeil "TextBody" auswählen und im Ersetzfenster (untere Teil) "Standard"

auswählen

  1. Zum Schluss "alle ersetzen" wählen

Jetzt ist der gesamte Text in dem Standard, der vorgegeben wurde oder den ich festgelegt habe. Das lässt sich aber leicht ändern, ebenso wie ein Abstand an jedem Absatzende.

Auch das lässt sich in einem Film darstellen. Er ist 3:30 Minuten lang und kann hier herunter geladen werden. (27MB). Zum direkten Abspielen lässt sich eine andere Erweiterung ausprobieren:

Hyperlinks entfernen

Das Prinzip wird auf dieser Seite erklärt. Dort steht:

  1. Laden Sie ein Dokument von der Art, für die Sie die URL-Erkennung ändern wollen.
  2. Wählen Sie Extras - AutoKorrektur-Optionen.
  3. Im Dialog AutoKorrektur wechseln Sie in das Register Optionen.
  4. Entfernen Sie die Markierung vor URL erkennen, werden Wörter nicht mehr automatisch durch Hyperlinks ersetzt.

Was fehlt ist der Schritt, dass ich nun immer noch den ganzen Text markieren und mit der rechten Maustaste die Option "entferne Hyperlink" wählen muss. Obwohl der Tipp zum Entfernen von Hyperlinks ins Irre führte, könnte es auf dieser Seite weitere nützliche Tipps für das Arbeiten mit LibreOffice geben.

Tabellen aus LibreOffice Calc importieren

In der Hilfe für LibreOffice steht:

  1. Öffnen Sie das Calc-Tabellendokument mit dem Zellbereich, den Sie einfügen möchten.
  2. Wählen Sie die Zellen im Tabellendokument durch Ziehen aus.
  3. Wählen Sie Bearbeiten - Kopieren.
  4. Führen Sie in Ihrem Textdokument einen der folgenden Schritte aus:
  • Wählen Sie Bearbeiten - Einfügen. Der Zellbereich wird als OLE-Objekt eingefügt. Um die Inhalte der Zellen zu bearbeiten, doppelklicken Sie auf das Objekt.
  • Wählen Sie Bearbeiten - Inhalte einfügen, und wählen eine der folgenden Optionen:

Das Ganze ginge auch per Drag and Drop. Bei der Auswahl "Inhalte einfügen" werden nur im RTF Format die Formeln aus der Tabelle übernommen. Noch ist mir keine geschickte Lösung eingefallen.

Links- und rechtsbündig in einer Zeile

Hier steht im OpenOffice Wiki:

Wenn man einen Absatz in einem TextDokument auf rechtsbündig stellt, genügt es, irgendwo die Tabulator-Taste zu drücken, um dann alles, was links des Tabulator-Sprunges steht, linksbündig am linken Seitenrand ausrichten zu lassen. Alles, was rechts des Tabulator-Sprungs steht, wird rechtsbündig am rechten Seitenrand ausgerichtet. In OpenOffice.org ab Version 2.0.1 (natürlich auch in LibreOffice) muss dazu unter Extras → Optionen → OpenOffice.org Writer → Kompatibilität die Option OpenOffice.org 1.1 Tabulator-Formatierungen verwenden aktiviert sein. Diese Einstellung gilt jedoch immer nur für das aktuell bearbeitete Dokument. Um dies für alle folgenden, auf der Standardvorlage basierenden Dokumente voreinzustellen muss die Option aktiviert und dann die Schaltfläche „Als Standard verwenden“ aktiviert werden.

Ändern von Groß- und Kleinschreibung

Hier steht in der Hilfe für LibreOffice: So legen Sie Großschreibung für Text fest

  1. Wählen Sie den Text aus, für den Sie die Großschreibung festlegen möchten.
  2. Wählen Sie Format - Groß-/Kleinschreibung - Großbuchstaben.

Die Verwandlung eines Textes in nur Kleinbuchstaben geht entsprechend anders herum, kurz: es werden nicht einfach die Zeichen formatiert, sondern unter "Formatieren" gibt es dazu einen Sonderpunkt.

Abstand von Absätzen

Ein wenig suchen musste ich schon, aber dann habe ich doch die Lösung für ein störendes Problem gefunden. Selbst wenn ich unter "Format"-"Abstand" den Abstand nach einem Absatz auf Null gesetzt hatte, wurde mir beim nächsten Absatz wieder ein Abstand von 0,21cm eingefügt. Die Lösung war:

  • Taste F11 drücken
  • Ein Fenster "Formatvorlagen" öffnet sich
  • Unter "Textkörper" rechter Mausklick und "ändern" wählen
  • Hier dann auf Null stellen und "Ok" klicken.

Das war aber nicht alles. Störend war (ist) vor allen Dingen, dass diese "Übung" in jedem Dokument neu gemacht werden muss. In meinen Einstellungen waren zudem die Abstände von 0,21cm nicht nur vorhanden, wenn ich auf "Textkörper" klickte, sondern auch, wenn der Absatz als "Standard" formatiert war.

Danach passierte es, dass ich bei einem verkleinerten Font am Ende eines Absatzes dieser wieder in der als "Standard" vorgegebene Größe verwandelt wurde. Einige Tipps deuteten darauf hin, dass es etwas mit der AutoKorrektur zu tun haben könnte. Jedoch konnte ich die Einstellungen dort nicht auf Anhieb ändern.

Überschriften bei doppelter Betätigung der Eingabetaste

Eine andere ungewollte und störende Sache war, dass sich bei einem doppelten Klick auf die Eingabetaste (auch als "Enter" oder "Return" bekannt), die ich bediente, um eine Leerzeile zu haben, plötzlich kurze Text als Überschrift formatiert bekam. Ich konnte jedes Mal mit STRG+Z die Änderung rückgängig machen, aber die Stelle wurde dabei markiert und nur durch das Bedienen der ESC Taste und Bewegen des Cursors konnte ich weiter schreiben.

Damit stellen sich zwei Fragen:

  1. Wie können "short cuts" Tastenkombinationen deaktiviert werden?
  2. Wie kann ich die Formatierungen bei "Standard" und "Textkörper" grundsätzlich ändern?

Short cuts ändern

Die Angaben auf dieser Seite

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
  1. Select Tools > Customize > Keyboard. The Customize dialog opens.
  2. To have the shortcut key assignment available only for Writer, select Writer in the upper right part of the dialog; otherwise select OpenOffice.org to make it available to all components.
  3. Next select the required function from the Category and Function lists.
  4. Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at the upper right.
  5. Click OK to savet the change.

lauten übersetzt: Rufe "Extras"-"Anpassen"-"Tastatur". Wähle oben rechts, ob die Änderungen für ganz Libre Office oder nur für den Writer gültig sein sollen. Die danach gegebene Auswahl war so umfangreich, dass ich erst einmal die Finger davon gelassen habe oder anders gesagt, ich habe die Möglichkeit nicht gefunden, nach einmal Enter den vorhergehenden Absatz auf "Standard" und nach zwei Mal Enter die Zeile davor zu einer Überschrift zu machen, auszuschalten oder durch eine anderen Tastenkombination zu ersetzen.

Neue Standardvorlage erstellen

Das wird hier beschrieben. Hier habe also entsprechend die Abstände zwischen den Absätzen bei der Formatierung "Textkörper" entfernt. Das schien beim Format "Standard" nicht der Fall zu sein. Dann habe ich mir noch Formatierungen für "Überschrift 1" und "Überschrift 2" ausgedacht. Danach habe ich die Textvorlage wie auf der obigen Seite beschrieben, gespeichert und bemerkte, etwas was nicht beschrieben wird. Da ist die Tatsache, dass ein Text, den ich erstelle, gleich mit abgespeichert wird. Bei jedem Dokument, das ich neu anlege, muss also als Erstes der gesamte Text gelöscht werden. Ich kann auch den gesamten Text erst löschen und dann die Vorlage speichern. Dabei sollte jedoch darauf geachtet werden, dass ich nicht ganz oben eine Überschrift stehen habe, denn dann würde mein Text immer mit einer Überschrift beginnen.

Spracheinstellung

Zu einer Zeit, als ich vorwiegend Tabellen in der türkischen Sprache erstellte, tauchte in meinen Dateien, nachdem ich sie mit "Türkisch" abgespeichert hatte, beim erneuten Aufruf wieder eine andere Sprache auf. Um das abzustellen, bin ich Tipps im Internet gefolgt und habe als Standardsprache Türkisch eingestellt.

Nun passierte das Gleiche in Tabellen, für die ich Englisch oder Deutsch als Sprache festgelegt hatte. Sie wurden bei jedem neuen Laden auf Türkisch angezeigt. Ich habe nun unter Extras-Optionen-Spracheinstellungen-Sprachen "Keine" aktiviert und hoffe, dass meine Tabellen nun jedes Mal in der Sprache geladen werden, die ich beim Erstellen festlegte.